Activar el repositorio kde-unstable y tener lo último de KDE en Archlinux

Como usuario de Archlinux estoy acostumbrado a estar siempre a la última en cuanto a actualizaciones, especialmente porque soy de los que habilitan los repositorios inestables en la configuración de pacman. Sin embargo, en muchas ocasiones los diferentes proyectos que proveen aplicaciones, programas, entornos de escritorio, espacios de trabajo, van un tanto más adelante que los mantenedores de los repositorios oficiales de las distribuciones GNU/Linux que usamos a diario (incluso con los repositorios inestables) y mientras el proyecto está en fase más avanzada, notamos que no estamos tan a la última como deseamos.

Uno de los casos es el del proyecto KDE. Mientras la gente de KDE trabajaba en el lanzamiento de la versión 5.6.95 de su entorno de escritorio Plasma y al mismo tiempo la versión 5.7 de este proyecto entraba en fase Beta, yo me encontraba con la versión 5.6.5 en mi instalación de Archlinux.

$ plasmashell --version
plasmashell 5.6.5

Aquí comencé a preguntarme cómo podría disponer de las últimas actualizaciones, es decir, de la versión 5.6.95 próxima a publicarse, la cual incluye muchas de las novedades que vienen con la siguiente (Plasma 5.7). Pues bien, en Archlinux disponemos del repositorio kde-unstable y para habilitarlo debemos editar el archivo /etc/pacman.conf.

$ sudo nano /etc/pacman.conf

/etc/pacman.conf


REPOSITORIES

[kde-unstable]
Include = /etc/pacman.d/mirrorlist
 
[testing]

Básicamente hemos agregado [kde-unstable] a nuestro listado de repositorios personalizados. Es importante colocarlo encima de los demás para que tenga prioridad sobre estos.

Ahora bastará con actualizar el sistema y volver a ejecutar el comando plasmashell --version.

$ sudo pacman -Syyu
...

$ plasmashell --version
plasmashell 5.6.95

 

Bien, hasta acá este pequeño artículo. Debo aclarar que al momento de preparar la entrada, la versión 5.6.95 aún no se lanzaba oficialmente. Hoy ya está disponible en repositorios oficiales de Archlinux. Sin embargo, igual sirve para futuras actualizaciones en fase previa a su lanzamiento.

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s